Update from Magento 2.2.5-dev to latest

Hello there,

 

a client popped up with a request of update of his Magento version – after a check I found the version as 2.2.5-dev Community Edition – the command line update: https://devdocs.magento.com/guides/v2.3/comp-mgr/cli/cli-upgrade.html not works – it ends with “Your requirements could not be resolved to an installable set of packages.”

Could be that the first installation was done by cloning the GIT repository? But in the project I am not find any reference to GIT ( for example: .git, .gitignore ).

 

Any tips to how can I sort this out?

 

Thank you in advance for any advice.

 

Cheers,

Vince