please help, magento 2.2.6 to 2.3 upgrade fails with composer

I tried to upgrade my 2.2.6 Magento install with composer following the tutorial on Magento Website, but “composer update” fails with these errors below:

 

 

Problem 1
– magento/inventory-composer-installer 1.0.3 requires composer-plugin-api ^1.1 -> no matching package found.
– magento/product-community-edition 2.3.0 requires magento/inventory-composer-metapackage ^1.0.3 -> satisfiable by magento/inventory-composer-metapackage[1.0.3].
– magento/inventory-composer-metapackage 1.0.3 requires magento/inventory-composer-installer ^1.0.3 -> satisfiable by magento/inventory-composer-installer[1.0.3].
– Installation request for magento/product-community-edition 2.3.0 -> satisfiable by magento/product-community-edition[2.3.0].

Potential causes:
– A typo in the package name
– The package is not available in a stable-enough version according to your minimum-stability setting
see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.