Magento 2: Problem updating Magento v2.2.1 to v2.3.2

i want to update my Magento to v2.3.2, when i run composer update, i get this error:

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for magento/product-community-edition 2.3.2 -> satisfiable by magento/product-community-edition[2.3.2].
    - Installation request for phpro/grumphp ^0.12.1 -> satisfiable by phpro/grumphp[v0.12.1].
    - magento/product-community-edition 2.3.2 requires symfony/console ~4.1.0 -> satisfiable by symfony/console[v4.1.0, v4.1.0-BETA1, v4.1.0-BETA2, v4.1.0-BETA3, v4.1.1, v4.1.10, v4.1.11, v4.1.12, v4.1.2, v4.1.3, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8, v4.1.9].
    - Can only install one of: symfony/console[v4.1.0, v2.8.38].
    - Can only install one of: symfony/console[v4.1.0-BETA1, v2.8.38].
    - Can only install one of: symfony/console[v4.1.0-BETA2, v2.8.38].
    - Can only install one of: symfony/console[v4.1.0-BETA3, v2.8.38].
    - Can only install one of: symfony/console[v4.1.1, v2.8.38].
    - Can only install one of: symfony/console[v4.1.10, v2.8.38].
    - Can only install one of: symfony/console[v4.1.11, v2.8.38].
    - Can only install one of: symfony/console[v4.1.12, v2.8.38].
    - Can only install one of: symfony/console[v4.1.2, v2.8.38].
    - Can only install one of: symfony/console[v4.1.3, v2.8.38].
    - Can only install one of: symfony/console[v4.1.4, v2.8.38].
    - Can only install one of: symfony/console[v4.1.5, v2.8.38].
    - Can only install one of: symfony/console[v4.1.6, v2.8.38].
    - Can only install one of: symfony/console[v4.1.7, v2.8.38].
    - Can only install one of: symfony/console[v4.1.8, v2.8.38].
    - Can only install one of: symfony/console[v4.1.9, v2.8.38].
    - Conclusion: install symfony/console v2.8.38

 Here is my composer.json:

{
    "name": "magento/project-community-edition",
    "description": "eCommerce Platform for Growth (Community Edition)",
    "type": "project",
    "version": "2.3.2",
    "license": [
        "OSL-3.0",
        "AFL-3.0"
    ],
    "require": {
        "composer/composer": "@alpha",
        "ebizmarts/mailchimp-lib": "^3.0",
        "magento/product-community-edition": "2.3.2",
        "phpro/grumphp": "^0.12.1"
    },
    "require-dev": {
        "friendsofphp/php-cs-fixer": "~2.10.1",
        "lusitanian/oauth": "~0.8.10",
        "pdepend/pdepend": "2.5.2",
        "phpmd/phpmd": "@stable",
        "phpunit/phpunit": "~6.2.0",
        "sebastian/phpcpd": "~3.0.0",
        "squizlabs/php_codesniffer": "3.2.2"
    },
    "config": {
        "use-include-path": true,
        "preferred-install": "dist",
        "sort-packages": true
    },
    "autoload": {
        "psr-4": {
            "Magento\Framework\": "lib/internal/Magento/Framework/",
            "Magento\Setup\": "setup/src/Magento/Setup/",
            "Magento\": "app/code/Magento/",
            "Zend\Mvc\Controller\": "setup/src/Zend/Mvc/Controller/"
        },
        "psr-0": {
            "": "app/code/"
        },
        "files": [
            "app/etc/NonComposerComponentRegistration.php"
        ]
    },
    "autoload-dev": {
        "psr-4": {
            "Magento\Sniffs\": "dev/tests/static/framework/Magento/Sniffs/",
            "Magento\Tools\": "dev/tools/Magento/Tools/",
            "Magento\Tools\Sanity\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
            "Magento\TestFramework\Inspection\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
            "Magento\TestFramework\Utility\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
        }
    },
    "minimum-stability": "alpha",
    "prefer-stable": true,
    "repositories": [
        {
            "type": "composer",
            "url": "https://repo.magento.com/"
        }
    ],
    "extra": {
        "magento-force": "override"
    }
}