Magento 2.x Version Upgrades

Upgrading from 2.3.2 to 2.3.3 problems

Upon trying to upgrade from 2.3.2 to 2.3.3 I’m getting the following errors:   composer require magento/product-community-edition 2.3.3 –update-with-all-dependencies./composer.json has been updatedLoading composer repositories with package informationUpdating dependencies (including require-dev)Your requirements could not be resolved to an installable set of packages. Problem 1– eadesignro/module-eacore 0.0.5 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.31) does not …

Upgrading from 2.3.2 to 2.3.3 problems Read More »

What’s the most exciting part of Magento 2.3.3?

I just wanted to know which one is the most effective update in Magento 2.3.3 release note:1. Security Patch: PSD2 compliance with core payment methods Fixes for 75 critical security issues 2. Availability of Varnish 6.2.0 3. Support the latest version of PHP 7.3.X 4. Performance Boost Techniques 5. Infrastructure Improvement (WYSIWYG editor has been upgraded to …

What’s the most exciting part of Magento 2.3.3? Read More »

Does CVE-2019-8144 Page Builder RCE apply to M2.2.x?

Does the Magento CVE-2019-8144 that was recently announced actually apply to M2.2.x since Page Builder wasn’t launched until M2.3.1?   Or, is M2.2.x vulnerable to the Page Builder RCE anyways because the vulnerable code is present?   I believe there could be a special effort to install Page Builder before 2.3.1, but that’s a special …

Does CVE-2019-8144 Page Builder RCE apply to M2.2.x? Read More »

Magento 2.1.18 versus latest vulnerability patches

Following this article: https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update versions of Magento prior to 2.1.19 are affected by the security holes. But there is no such version as 2.1.19 provided by composer. The article also states that The Magento 2.2.10 software release marks the final supported software release for Magento version 2.1.x.   Does that mean that 2.2.10 is the least …

Magento 2.1.18 versus latest vulnerability patches Read More »

please help, magento 2.2.6 to 2.3 upgrade fails with composer

I tried to upgrade my 2.2.6 Magento install with composer following the tutorial on Magento Website, but “composer update” fails with these errors below:     Problem 1– magento/inventory-composer-installer 1.0.3 requires composer-plugin-api ^1.1 -> no matching package found.– magento/product-community-edition 2.3.0 requires magento/inventory-composer-metapackage ^1.0.3 -> satisfiable by magento/inventory-composer-metapackage[1.0.3].– magento/inventory-composer-metapackage 1.0.3 requires magento/inventory-composer-installer ^1.0.3 -> satisfiable by …

please help, magento 2.2.6 to 2.3 upgrade fails with composer Read More »

Custom theme not working after update to Magento 2.3.2

Hi am upgrading a store from Magento 2.1.9 to 2.3.2, and I’m having issues with my current theme, which I created for the existing site. On my dev server, the site works as expected, however on the live server, the theme’s default.xml and default_head_blocks.xml files are ignored. The only difference between the 3 servers (Live, …

Custom theme not working after update to Magento 2.3.2 Read More »

Did Magento change the language of API error messages with 2.3.2?

Starting with the upgrade to 2.3.2 it seems like error messages of the REST API are localized now. For example the error message “Database deadlock found when trying to get lock” is now “Database deadlock gedetecteerd tijdens het verkrijgen van een lock” in a dutch store. This makes it hard to catch error messages in …

Did Magento change the language of API error messages with 2.3.2? Read More »