Magento 2.x Version Upgrades

Foreign key constraint is incorrectly formed

1 exception(s): Exception #0 (MagentoFrameworkExceptionLocalizedException): Please upgrade your database: Run “bin/magento setup:upgrade” from the Magento root directory. The following modules are outdated: Magento_AuthorizenetAcceptjs schema: current version – none, required version – 1.0.0 Magento_AuthorizenetAcceptjs data: current version – none, required version – 1.0.0 Amazon_Core schema: current version – none, required version – 3.2.9 Amazon_Core data: current …

Foreign key constraint is incorrectly formed Read More »

Magento 2: Problem updating Magento v2.2.1 to v2.3.2

i want to update my Magento to v2.3.2, when i run composer update, i get this error: Your requirements could not be resolved to an installable set of packages. Problem 1 – Installation request for magento/product-community-edition 2.3.2 -> satisfiable by magento/product-community-edition[2.3.2]. – Installation request for phpro/grumphp ^0.12.1 -> satisfiable by phpro/grumphp[v0.12.1]. – magento/product-community-edition 2.3.2 requires symfony/console …

Magento 2: Problem updating Magento v2.2.1 to v2.3.2 Read More »

Magento ver. 2.2.6 ==> 2.3 ==> magento-coding-standard 1.0.2 required

Hello all,    on trying to upgrade from magento 2.2.6 to 2.3 (CE) I get the following error – does anybody know how to get this fixed? Btw – I do not want to develop stuff for my magento application.    Check Component Dependency We found conflicting component dependencies. Hide detail Command “update” failed: Loading composer …

Magento ver. 2.2.6 ==> 2.3 ==> magento-coding-standard 1.0.2 required

Read More »